Aperture 2.0 Hits the Streets

| 3 Comments

After months of speculation by the Aperture user community, Apple today released Aperture 2.0 with a raft of new image adjustment tools, an overhauled Raw decoder, major speed improvements, and additional camera support.

aperture2_hud_tds.jpg

The bulk of these changes can be loosely corralled into four areas:

  • Interface Changes, cleaner looking (and easier to understand) UI, including the tabbed inspector, double-click behaviors, and the new All Projects, which is similar to Events in iPhoto.
  • Performance Improvements, including an optimized database for better searching and browsing, and Quick Previews that use available Jpegs instead of always decoding the Raw file from scratch. Photographers can use this mode for everything but image editing.
  • Image Decoding and Adjusting, including the Raw 2.0 decoder and a host of new editing tools. Aperture now includes Baseline DNG that enables users to work with DNGs, even if the native Raw format isn't supported by Aperture.
  • New Camera Support, featuring Canon G9, Canon EOS 1Ds Mark III, Nikon D300, Nikon D3, Hasselblad CF-22, Hasselblad CF-39, Leaf Aptus 75s, and the Sony Alpha DSLR-A700.

New users can now move over to Aperture for a cool $199. That's $100 less than the previous version. If you already own a copy, you can upgrade for $99. There's also a 30 day trial version available for download right now. If you like it, you can simply purchase an upgrade or full price registration number.

If you want to learn more about Aperture 2.0, visit Inside Aperture, where there's a new podcast interview with product manager Joe Schorr about the new features in 2.0, and a variety of blog posts by photographers who have been using the new app.

Technorati Tags: , , ,

3 Comments

Something I've not seen mentioned yet on the various sites I've already visited today is the issue of Aperture's compatibility with Time Machine. I seem to recall there was some sort of an issue with Time Machine corrupting Aperture databases when Leopard first came out.

Was that solved already and I just missed it? Is it solved with Aperture v2? Surely it's not still an issue??

After spending a while late last year comparing the demo versions of each product, I decided that LightRoom was going to be the product for me, but had been holding off with from the final commitment (getting out my credit card). I guess that I should re-assess Aperture now... :-)

First, you should take a close look at both Aperture and Lightroom. Both have demo versions. Aperture is now $199.

As for Time Machine, it doesn't corrupt your Aperture library, but I wouldn't use it for that purpose. Use Aperture's Vault system for incremental backup. It's better suited to the task.

As an Aperture user who doesn't yet own one of the somewhat-recently-released Nikons or Canons, I'm disappointed in Apple's decision to only support the D300, D3, and 1Ds Mark III only in Aperture 2.

Aperture 1.5 was the current version of the software at the time these cameras were released, and remained so for a couple months. Adobe managed to add support for these cameras to its current software line, and did it in a timely manner. The people who owned these recent cameras were left hanging by Apple.

I'm going to stick with Aperture 1.5 until I replace my camera - then I think I'll see what Adobe's offering at that point. If Aperture 2 doesn't blow it away, I'll probably switch. I prefer Aperture's workflow, but - and it surprises me to say this - it looks like Adobe is going to be much better in the support department.

Leave a comment